Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / pptp-linux / pptp-linux_1.7.1.bb
1 DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
2 and OpenBSD client for the proprietary Microsoft Point-to-Point \
3 Tunneling Protocol, PPTP. Allows connection to a PPTP based \
4 Virtual Private Network (VPN) as used by employers and some \
5 cable and ADSL internet service providers."
6 HOMEPAGE = "http://pptpclient.sourceforge.net"
7 SECTION = "network"
8 LICENSE = "GPL"
9 RDEPENDS = "ppp"
10 PR = "r0"
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
13            file://options.pptp"
14
15 S = "${WORKDIR}/pptp-${PV}"
16
17 do_compile() {
18         oe_runmake
19 }
20 do_install() {
21         install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
22         install -m 555 pptp ${D}${sbindir}
23         install -m 644 pptp.8 ${D}${mandir}/man8
24         install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
25 }