Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / ppp-dialin / ppp-dialin_0.1.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Enables PPP dial-in through a serial connection"
3 DEPENDS = "ppp"
4 RDEPENDS = "ppp"
5 PR = "r6"
6 LICENSE = "MIT"
7
8 SRC_URI = "file://host-peer \
9            file://ppp-dialin"
10
11 do_install() {
12         install -d ${D}${sysconfdir}/ppp/peers
13         install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
14
15         install -d ${D}${sbindir}
16         install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
17 }
18
19 PACKAGE_ARCH = "all"
20
21 pkg_postinst() {
22 if test "x$D" != "x"; then
23         exit 1
24 else
25     grep "^ppp:" /etc/passwd > /dev/null || adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp 
26 fi
27 }
28
29 pkg_postrm() {
30 if test "x$D" != "x"; then
31         exit 1
32 else
33         deluser ppp || true
34 fi
35 }