increase dvbapp PR.
[vuplus_openembedded] / recipes / ppp / ppp_2.4.1.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
3 HOMEPAGE = "http://samba.org/ppp/"
4 LICENSE = "BSD GPLv2"
5 PR = "r7"
6
7 SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
8         file://pppd.patch;patch=1 \
9         file://man.patch;patch=1 \
10         file://cifdefroute.dif;patch=1 \
11         file://pppd-resolv-varrun.patch;patch=1 \
12         file://pon \
13         file://poff \
14         file://init \
15         file://ip-up \
16         file://ip-down \
17         file://08setupdns \
18         file://92removedns"
19
20 SRC_URI_append_nylon = " file://ppp-tdbread.patch;patch=1"
21
22 inherit autotools
23
24 EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
25 EXTRA_OECONF = "--disable-strip"
26
27 do_install_append () {
28         install -d ${D}${bindir}/ ${D}${sysconfdir}/init.d
29         install -m 0755 ${WORKDIR}/pon ${D}${bindir}/pon
30         install -m 0755 ${WORKDIR}/poff ${D}${bindir}/poff
31         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ppp
32         install -m 0755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/
33         install -m 0755 ${WORKDIR}/ip-down ${D}${sysconfdir}/ppp/
34         install -d ${D}${sysconfdir}/ppp/ip-up.d/
35         install -d ${D}${sysconfdir}/ppp/ip-down.d/
36         install -m 0755 ${WORKDIR}/08setupdns ${D}${sysconfdir}/ppp/ip-up.d/
37         install -m 0755 ${WORKDIR}/92removedns ${D}${sysconfdir}/ppp/ip-down.d/
38 }
39
40 CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options"
41
42 pkg_postinst() {
43 if test "x$D" != "x"; then
44         exit 1
45 else
46         chmod u+s ${sbindir}/pppd
47 fi
48 }