increase dvbapp PR.
[vuplus_openembedded] / recipes / powervr-drivers / omap3-sgx-modules_1.4.14.2514.bb
1 DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2 LICENSE = "GPLv2"
3
4 PR_append = "a"
5
6 # download required binary distribution from:
7 # http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
8
9 TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
10 require ../ti/ti-eula-unpack.inc
11
12 SGXPV = "3_01_00_02"
13 IMGPV = "1.4.14.2514"
14 BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
15
16 SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
17            file://0001-Compile-fixes-for-recent-kernels.patch;patch=1 \
18 "
19 S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
20
21 inherit module
22
23 PVRBUILD = "release"
24
25 INHIBIT_PACKAGE_STRIP = "1"
26
27 MAKE_TARGETS = " BUILD=${PVRBUILD}"
28
29 do_install() {
30         mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
31         cp ${S}/pvrsrvkm.ko \
32            ${S}/services4/3rdparty/dc_omap3430_linux/omaplfb.ko  \
33            ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
34            ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
35 }