increase dvbapp PR.
[vuplus_openembedded] / recipes / powervr-drivers / omap3-sgx-modules_1.3.13.1607.bb
1 DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2 LICENSE = "GPLv2"
3
4 inherit module
5
6 SRC_URI = "file://omap3-sgx-modules-${PV}.tar.bz2 \
7            file://0002-Compile-fixes-for-DSS2.patch;patch=1 \
8            file://rotation-dss2.patch;patch=1 \
9            file://build_es3.x_sgx.patch;patch=1 \
10            file://proc-interface.patch;patch=1 \
11            file://0001-Compile-fixes-for-recent-kernels.patch;patch=1 \
12 "
13
14 PVRBUILD = "release"
15
16 INHIBIT_PACKAGE_STRIP = "1"
17
18 MAKE_TARGETS = " BUILD=${PVRBUILD}"
19
20 do_install() {
21         mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
22         cp ${S}/pvrsrvkm.ko ${S}/services4/3rdparty/dc_omap3430_linux/omaplfb.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
23 }