Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / powervr-drivers / omap3-sgx-modules_1.2.12.838.bb
1 DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2 LICENSE = "GPLv2"
3
4 inherit module
5
6 SRC_URI = "http://dominion.thruhere.net/koen/OE/omap3-sgx-modules-${PV}.tar.bz2 \
7 "
8
9 MAKE_TARGETS = "BUILD=debug"
10
11 do_compile_prepend() {
12         cd ${S}/eurasiacon/build/linux/omap3430_linux/kbuild/
13 }
14
15 do_install() {
16         cd ${S}/eurasiacon/build/linux/omap3430_linux/kbuild/
17         mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
18         cp ${WORKDIR}/${PN}-${PV}/eurasiacon/binary_omap3430_linux_debug/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
19 }