increase dvbapp PR.
[vuplus_openembedded] / recipes / powervr-drivers / libgles-omap3_3.00.00.09.bb
1 require libgles-omap3.inc
2
3 DEFAULT_PREFERENCE = "1"
4 # download required binary distribution from:
5 # http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_00_00_09.bin
6
7 PR = "r2"
8
9 SGXPV = "3_00_00_09"
10 IMGPV = "1.3.13.1832"
11 BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
12
13 # The ES2.x and ES3.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
14 do_install_append() {
15         install -d ${D}${libdir}/ES3.0
16         install -d ${D}${libdir}/ES2.0
17         install -d ${D}${bindir}/ES3.0
18         install -d ${D}${bindir}/ES2.0
19
20         cp ${S}/gfx_rel_es2.x/lib* ${D}${libdir}/ES2.0/
21         cp ${S}/gfx_rel_es2.x/p[dv]* ${D}${bindir}/ES2.0/
22
23         cp ${D}${libdir}/lib*${IMGPV} ${D}${libdir}/ES3.0/
24         cp ${D}${bindir}/p[dv]* ${D}${bindir}/ES3.0
25 }
26
27 # Quality control is really poor on these SDKs, so hack around the latest madness:
28 FILES_${PN} += "${libdir}/*.so"
29 FILES_${PN}-dev = "${includedir}"
30