increase dvbapp PR.
[vuplus_openembedded] / recipes / portabase / metakit_2.4.9.3.bb
1 SECTION = "libs"
2 DESCRIPTION = "Metakit is an efficient embedded database library with a small \
3 footprint. It fills the gap between flat-file, relational, object-oriented, and \
4 tree-structured databases, supporting relational joins, serialization, nested structures,\
5 and instant schema evolution."
6 LICENSE = "MetaKit"
7 HOMEPAGE = "http://www.equi4.com/metakit.html"
8
9 SRC_URI = "http://www.equi4.com/pub/mk/metakit-${PV}.tar.gz \
10            file://metakit-2.4.9.3.patch;patch=1"
11 PR = "r3"
12
13 FILES_${PN} += " ${libdir}/*.so"
14
15 do_configure_prepend() {
16
17 #       cp ${STAGING_DATADIR}/libtool/*.* ${S}/unix/scripts/
18
19 }
20
21 do_configure () {
22
23         cd builds
24         ../unix/configure \
25                    --build=${BUILD_SYS} \
26                     --host=${HOST_SYS} \
27                     --target=${TARGET_SYS} \
28                     --prefix=${prefix} \
29                     --exec_prefix=${exec_prefix} \
30                     --bindir=${bindir} \
31                     --sbindir=${sbindir} \
32                     --libexecdir=${libexecdir} \
33                     --datadir=${datadir} \
34                     --sysconfdir=${sysconfdir} \
35                     --sharedstatedir=${sharedstatedir} \
36                     --localstatedir=${localstatedir} \
37                     --libdir=${libdir} \
38                     --includedir=${includedir} \
39                     --oldincludedir=${oldincludedir} \
40                     --infodir=${infodir} \
41                     --mandir=${mandir} \
42                         ${EXTRA_OECONF} \
43                     $@;
44
45 }
46
47 do_stage() {
48         oe_libinstall -a -so -C builds/.libs libmk4 ${STAGING_LIBDIR}
49         install -d ${STAGING_INCDIR}/
50         for X in mk4.h mk4.inl
51         do
52                 install -m 0644 include/${X} ${STAGING_INCDIR}/${X}
53         done
54
55 }
56
57 do_compile () {
58         cd builds
59         oe_runmake
60 }
61
62 do_install() {
63         oe_libinstall -so -C builds/.libs libmk4 ${D}${libdir}
64 }
65