increase dvbapp PR.
[vuplus_openembedded] / recipes / poptop / poptop_1.3.4.bb
1 DESCRIPTION = "Poptop is the PPTP server solution for Linux Using Poptop, \
2 Linux servers can now function seamlessly in a PPTP VPN environment. This \
3 enables administrators to leverage the considerable benefits of both \
4 Microsoft and Linux operating systems The current release version supports \
5 Windows 95/98/Me/NT/2000/XP PPTP clients and Linux PPTP clients"
6 HOMEPAGE = "http://www.poptop.org/"
7 SECTION = "network"
8 LICENSE = "GPL"
9 RDEPENDS_${PN} = "ppp"
10 RDEPENDS_${PN}-logwtmp-plugin = "${PN}"
11 PR = "r1"
12
13 SRC_URI = "${SOURCEFORGE_MIRROR}/poptop/pptpd-${PV}.tar.gz \
14            file://fix-plugins-install.patch;patch=1 \
15            file://pptpd.init"
16
17 S = "${WORKDIR}/pptpd-${PV}"
18
19 inherit autotools update-rc.d
20
21 do_install_append() {
22         # Install init script
23         install -m 0755 -d ${D}${sysconfdir}/init.d
24         install -m 0755 ${WORKDIR}/pptpd.init ${D}${sysconfdir}/init.d/pptpd
25         # Install
26         install -d ${D}${sbindir} ${D}/${sysconfdir} ${D}/${sysconfdir}/ppp
27         install -m 0644 samples/options.pptpd ${D}/${sysconfdir}/ppp/
28         install -m 0644 samples/pptpd.conf ${D}/${sysconfdir}/
29         # broken
30         rm -f ${D}${libdir}/pptpd/pptpd-logwtmp.so
31 }
32
33 PACKAGES = "${PN}-dbg ${PN}-bcrelay ${PN} ${PN}-doc"
34
35 FILES_${PN}-bcrelay = "${sbindir}/bcrelay"
36
37 CONFFILES_${PN} = "${sysconfdir}/pptpd.conf \
38                    ${sysconfdir}/ppp/options.pptpd"
39
40 INITSCRIPT_NAME = "pptpd"
41 INITSCRIPT_PARAMS = "defaults 92 8"