increase dvbapp PR.
[vuplus_openembedded] / recipes / perl / libhtml-mason-perl_1.35.bb
1 DESCRIPTION = "Mason - High-performance, dynamic web site authoring system"
2 SECTION = "libs"
3 LICENSE = "Artistic|GPL"
4 DEPENDS = "libexception-class-perl-native libparams-validate-perl-native \
5            libcache-cache-perl-native libclass-container-perl-native"
6 RDEPENDS_${PN} = "libexception-class-perl libparams-validate-perl \
7         libcache-cache-perl libclass-container-perl perl-module-strict \
8         perl-module-warnings perl-module-file-basename perl-module-file-path \
9         perl-module-file-spec perl-module-file-spec-unix perl-module-file-temp \
10         perl-module-carp-heavy perl-module-io-handle perl-module-io \
11         perl-module-exporter-heavy perl-module-cwd perl-module-scalar-util \
12         perl-module-list-util perl-module-bytes perl-module-file-glob \
13         perl-module-data-dumper"
14 PR = "r1"
15
16 SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/HTML-Mason-${PV}.tar.gz"
17
18 S = "${WORKDIR}/HTML-Mason-${PV}"
19
20 do_stage() {
21         :
22 }
23
24 inherit cpan_build
25
26 do_install_append () {
27         # Fix up paths to the perl interpreter
28         for i in ${D}${bindir}/*.pl; do
29                 sed -i -e "s#${STAGING_BINDIR}/perl#${bindir}/perl#g" $i
30         done
31
32         # Install the html documentation and example files
33         install -m 0755 -d ${D}${docdir}/${PN}/html \
34                  ${D}${docdir}/${PN}/examples/samples \
35                  ${D}${docdir}/${PN}/examples/eg
36         cp -pRP ${S}/htdocs ${D}${docdir}/${PN}/html
37         cp -pRP ${S}/eg ${D}${docdir}/${PN}/examples/eg
38         cp -pRP ${S}/samples ${D}${docdir}/${PN}/examples/samples
39 }
40