Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / pciutils / pciutils_3.1.2.bb
1 DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
2 to PCI bus configuration space and several utilities based on this library.'
3 DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
4 SECTION = "console/utils"
5 HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
6 LICENSE = "GPLv2"
7 DEPENDS = "zlib"
8
9 SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
10            file://pciutils.patch;patch=1 "
11 SRC_URI_append_nylon = "file://gcc-3-compatibility.patch;patch=1 "
12
13 PARALLEL_MAKE = ""
14
15 PR = "r6"
16
17 EXTRA_OEMAKE += "'STRIP = ' PREFIX=${prefix} LIBDIR=${libdir}"
18 export SHARED=yes
19 export DESTDIR = "${D}"
20 export PREFIX = "${prefix}"
21 export SBINDIR = "${sbindir}"
22 export SHAREDIR = "${datadir}"
23 export MANDIR = "${mandir}"
24 export IDSDIR = "${datadir}"
25
26 do_configure () {
27         export ZLIB=yes
28         (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
29 }
30
31 do_install () {
32         oe_runmake install install-lib
33
34         # "make install" misses the debug file for the library
35         oe_libinstall -so -C lib libpci ${D}/${libdir}
36
37         # Some older versions of hal may need the uncompressed version.
38         # We install it in a separate package, pciutils-ids-uncompressed.
39         install -m 0644 ${S}/pci.ids ${D}/${datadir}
40 }
41
42 PACKAGES =+ "${PN}-ids ${PN}-ids-uncompressed"
43 FILES_${PN}-ids = "${datadir}/pci.ids.gz"
44 FILES_${PN}-ids-uncompressed = "${datadir}/pci.ids"