Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / otpcalc / otpcalc_0.97.bb
1 HOMEPAGE = "http://killa.net/infosec/otpCalc/"
2 DESCRIPTION = "An OTP and S/Key calculator for X"
3 SECTION = "x11"
4 LICENSE = "GPL"
5 DEPENDS = "gtk+ openssl"
6 PR = "r1"
7
8 S = "${WORKDIR}/otpCalc-${PV}"
9
10 SRC_URI = "http://killa.net/infosec/otpCalc/otpCalc-${PV}.tar.gz \
11         file://otpcalc-man-table-format.diff;patch=1 \
12         file://otpcalc-0.97-badindex.diff;patch=1 \
13         file://otpcalc-crypto-proto.diff;patch=1 \
14         file://otpcalc-0.97-gtk2-gentoo.patch;patch=1 \
15         "
16
17 inherit autotools pkgconfig
18
19 do_install() {
20         install -d ${D}${bindir}
21         install -d ${D}${mandir}/man1
22         cat ${S}/otpCalc.man | sed -e "s/VERSION/${PV}/g" | gzip -c9 > ${D}${mandir}/man1/otpCalc.1.gz
23         install -m 755 otpCalc ${D}${bindir}
24 }
25
26