enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / opkg / opkg-nogpg-nocurl-slugos_svn.bb
1 # This recipe is a regeneration of the original opkg-nogpg-nocurl_svn.bb
2 # recipe, intended for temporary use by the SlugOS distro.
3
4 # DO NOT USE this recipe for anything other than SlugOS and svn version 160
5 # of the opkg sources.  Also note that This recipe will be removed without
6 # notice when the unfortunate commits to the original opkg-nogpg-nocurl_svn.bb
7 # recipe are repaired, the small-memory patches updated to a newer opkg svn
8 # version, and appropriate testing confirms that the resulting binary actually
9 # works correctly on a 32MB system.
10
11 # DO NOT CHANGE THIS RECIPE!
12
13 require opkg.inc
14
15 DEPENDS = ""
16 PROVIDES += "opkg"
17
18 SRC_URI += " \
19             file://isatty.patch;patch=1 \
20             file://opkg_wget.patch;patch=1;maxrev=180 \
21             file://reduce-nogpg-noise.patch;patch=1;maxrev=180 \
22             file://opkg_wget_nogpg_01_use_vfork_gunzip.patch;patch=1 \
23             file://opkg_wget_nogpg_02_use_vfork_system.patch;patch=1 \
24             file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
25             file://opkg_wget_nogpg_04_default_tmpdir.patch;patch=1 \
26            "
27 PR = "${INC_PR}"
28
29 SRCREV = "${SRCREV_pn-opkg}"
30
31 EXTRA_OECONF += "--disable-gpg --enable-static --disable-shared"
32
33 # Not sure this is needed; needs to be investigated and removed if not
34 do_stage() {
35         autotools_stage_all
36 }
37
38 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
39 do_configure_prepend() {
40         sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
41 }
42
43 PACKAGES =+ "libopkg-dev"
44
45 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
46 # not happens automatically for opkg-nogpg:
47 FILES_${PN} += "${datadir}/opkg/intercept"
48
49 # Define a variable to allow distros to run configure earlier.
50 # (for example, to enable loading of ethernet kernel modules before networking starts)
51 OPKG_INIT_POSITION = "98"
52 OPKG_INIT_POSITION_slugos = "41"
53
54 pkg_postinst_${PN} () {
55   update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
56 }
57
58 pkg_postrm_${PN} () {
59   update-alternatives --remove opkg ${bindir}/opkg-cl
60 }
61
62 DEFAULT_PREFERENCE = "-1"