Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / opensync / wbxml2_0.9.2.bb
1 DESCRIPTION = "WBXML parsing and encoding library"
2 LICENSE = "LGPL"
3
4 DEPENDS = "expat popt"
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${PN}-${PV}.tar.gz \
7            file://00-fix-includes.patch;patch=1 \
8            file://01-anonymous-support-and-misc-fixes.patch;patch=1 \
9            file://02-namespaces.patch;patch=1 \
10            file://04_saxlike_entity_parsing.patch;patch=1 \
11            file://05-syncml-fixes.patch;patch=1 \
12            file://06-no-install-docs.patch;patch=1 \
13            file://07-current_attr_null.patch;patch=1 \
14            file://08-maxsize-translation-table.patch;patch=1;pnum=0 \
15            "
16
17 inherit autotools pkgconfig
18
19 do_stage() {
20         autotools_stage_all
21 }
22
23 PACKAGES += "${PN}-tools"
24
25 FILES_${PN}-tools = "${bindir}"
26 FILES_${PN} = "${libdir}/*.so.*"
27
28
29