increase dvbapp PR.
[vuplus_openembedded] / recipes / openmoko2 / openmoko-asu-om20072-support.bb
1 DESCRIPTION = "Theme support and defaults to integrate OM2007.2 in the April Software Update"
2 LICENSE = "GPL"
3 SECTION = "x11"
4 RDEPENDS_${PN} = "openmoko-common2"
5
6 ALLOW_EMPTY_${PN} = "1"
7 PACKAGE_ARCH = "all"
8
9 pkg_postinst_${PN} () {
10 #!/bin/sh -e
11 if [ "x$D" != "x" ]; then
12     exit 1
13 fi
14
15 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Moko
16 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme openmoko-standard
17 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 5"
18 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/wallpaper ${datadir}/pixmaps/wallpaper.png
19 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/digital_clock 1
20 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/poky/peripherals/mouse/drag_threshold 8
21 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/openmoko/neod/power_management 2
22 # gstreamer audio settings
23 #gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosink pulsesink
24 #gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosrc pulsesrc
25
26 }
27