Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / openmoko-tools / openmoko-set-root-password.bb
1 DESCRIPTION = "Set a root password for your Neo."
2 SUMMARY = "On installation you will be prompted to set a root password. With \
3 this password you can then log into the machine."
4 LICENSE = "GPL"
5 DEPENDS = "gtk+"
6
7 SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=root-password;proto=http"
8 S = "${WORKDIR}/root-password"
9 PV = "1.0+svnr${SRCPV}"
10 PE = "1"
11 PR = "r1"
12
13 do_compile () {
14     cd ${S}
15     oe_runmake
16 }
17
18 do_install() {
19     install -d ${D}/${sbindir}
20     install -m 0755 ${S}/root-password ${D}/${sbindir}/${PN}
21 }
22
23 pkg_postinst_${PN} () {
24     # assume we use display 0
25     DISPLAY=:0 ${sbindir}/${PN}
26 }