Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / openmoko-projects / illume-theme-asu_svn.bb
1 DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
2 HOMEPAGE = "http://illume.projects.openmoko.org/"
3 LICENSE = "MIT/BSD"
4 DEPENDS = "edje-native eet-native"
5 RPROVIDES_${PN} = "illume-theme"
6 RCONFLICTS = "illume-config"
7 PV = "0.0+svnr${SRCPV}"
8 PR = "r9"
9
10 SRC_URI = "svn://svn.openmoko.org/trunk/src/target/themes/;module=illume-theme-asu;proto=http"
11
12 S = "${WORKDIR}/illume-theme-asu"
13
14 do_compile() {
15     cd misc-data/asu && ./build.sh && cd ../..
16     cd misc-data/asu_init && ./build.sh && cd ../..
17     cd config
18     eet -e e.cfg config e.src 1
19     eet -e module.battery.cfg config module.battery.src 1
20     eet -e module.illume.cfg config module.illume.src 1
21 }
22
23 do_install() {
24     install -d ${D}${sysconfdir}/enlightenment
25     install -d ${D}${datadir}/enlightenment/data/themes
26     install -d ${D}${datadir}/enlightenment/data/init
27     install -d ${D}${datadir}/enlightenment/data/config/asu
28     # Make asu the default profile
29     echo 'E_PROFILE="-profile asu"' > ${D}${sysconfdir}/enlightenment/default_profile
30     install -m 0644 ${S}/misc-data/asu/asu.edj ${D}${datadir}/enlightenment/data/themes/asu.edj
31     install -m 0644 ${S}/misc-data/asu_init/asu_init.edj ${D}${datadir}/enlightenment/data/init/asu_init.edj
32     install -m 0644 ${S}/config/*.cfg ${D}${datadir}/enlightenment/data/config/asu
33 }
34
35 PACKAGE_ARCH_${PN} = "all"
36 PACKAGES = "\
37     ${PN} \
38 "
39 FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
40
41 CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"