change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / openmoko-3rdparty / calc_git.bb
1 DESCRIPTION = "A dead simple calculator. It's advantage is that it's elementary-themed"
2 HOMEPAGE = "http://github.com/spaetz/calc"
3 AUTHOR = "Sebastian Spaeth <Sebastian@SSpaeth.de>"
4 SHR_RELEASE ?= "shr"
5 LICENSE  = "MIT"
6 RDEPENDS = "python-elementary python python-edbus"
7 SECTION = "x11/application"
8 SRCREV ?= "1c17792094eb"
9 PV = "0.0.1+gitr${SRCREV}"
10 PR = "r1"
11
12 DEFAULT_PREFERENCE = "-1"
13
14 SRC_URI = "git://github.com/spaetz/calc.git;protocol=http;branch=master"
15 S = "${WORKDIR}/git"
16
17 do_install(){
18         install -d ${D}${datadir}/applications
19         install -m 0644 ${S}/data/elementary-calculator.desktop ${D}${datadir}/applications/
20         install -d ${D}${datadir}/pixmaps
21         install -m 0644 ${S}/data/calculator.png ${D}${datadir}/pixmaps/
22         install -d ${D}${bindir}
23         install -m 0744 ${S}/calc ${D}${bindir}/
24 }
25
26 FILES_${PN} += "${prefix}/share/pixmaps"
27 FILES_${PN} += "${prefix}/share/applications"