increase dvbapp PR.
[vuplus_openembedded] / recipes / openmoko-3rdparty / babiloo-efl_bzr.bb
1 DESCRIPTION = "EFL Dictionary Viewer. It supports dictionaries in SDictionary and StarDict format."
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 AUTHOR = "Luca Vaudano <vaudano@gmail.com>"
6 HOMEPAGE = "http://babiloo-project.org"
7 RDEPENDS = "python-elementary python-compression python-misc python-netclient"
8
9 PACKAGE_ARCH = "all"
10
11 DEFAULT_PREFERENCE = "-1"
12 PV = "2.0.9-bzrr${SRCPV}"
13
14 SRC_URI = "bzr://bazaar.launchpad.net/~vaudano/babiloo/efl"
15
16 S = "${WORKDIR}/efl"
17
18 do_install() {
19         install -d "${D}${datadir}/babiloo"
20         cp -a "${S}/core" "${D}${datadir}/babiloo/"
21         cp -a "${S}/efl" "${D}${datadir}/babiloo/"
22         cp -a "${S}/images" "${D}${datadir}/babiloo/"
23         cp -a "${S}/dicts" "${D}${datadir}/babiloo/"
24         install -m 0755 "${S}/run.py" "${D}${datadir}/babiloo/"
25         install -d "${D}${bindir}"
26         ln -s "${datadir}/babiloo/run.py" "${D}${bindir}/babiloo"
27         install -d "${D}${datadir}/pixmaps"
28         install -m 0644 "${S}/images/babiloo.png" "${D}${datadir}/pixmaps"
29         install -d "${D}${datadir}/applications"
30         install -m 0644 "${S}/babiloo.desktop" "${D}${datadir}/applications"
31
32         install -d "${D}${datadir}"
33         cp -a "${S}/locale" "${D}${datadir}/"
34         find ${D}${datadir}/locale -name *.po -exec rm {} \;
35         rm -f ${D}${datadir}/locale/babiloo.pot
36
37         install -d "${D}${datadir}/doc"
38         install -m 0644 "${S}/doc/efl/babiloo.pdf" "${D}${datadir}/doc/"
39 }
40
41 FILES_${PN} += "${datadir}/babiloo"