increase dvbapp PR.
[vuplus_openembedded] / recipes / openmoko-3rdparty / babiloo-efl_2.0.9-4.bb
1 DESCRIPTION = "EFL Dictionary Viewer. It supports dictionaries in SDictionary and StarDict format."
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 AUTHOR = "Luca Vaudano <vaudano@gmail.com>"
6 HOMEPAGE = "http://babiloo-project.org"
7 RDEPENDS = "python-elementary python-compression python-misc python-netclient"
8
9 PACKAGE_ARCH = "all"
10
11 PV = "2.0.9-4"
12 PR = "r1"
13
14 SRC_URI = "http://bazaar.launchpad.net/%7Evaudano/babiloo/efl/download/head%3A/babiloo_2.0.94.tar.g-20091201105555-efky7gi6fkm39xw8-2/babiloo_2.0.9-4.tar.gz;name=tarball"
15 SRC_URI[tarball.md5sum] = "f5f25daff7accb8d409fa9f94c49fc17"
16 SRC_URI[tarball.sha256sum] = "28fc4550f986512aaa96ebf776f16d3cb9d9b493ac1805642def54c8167a0f74"
17
18 S = "${WORKDIR}/babiloo"
19
20 do_install() {
21         install -d "${D}${datadir}/babiloo"
22         install -d "${D}${datadir}/babiloo/dicts"
23
24         cp -a "${S}/core" "${D}${datadir}/babiloo/"
25         cp -a "${S}/efl" "${D}${datadir}/babiloo/"
26         cp -a "${S}/images" "${D}${datadir}/babiloo/"
27         install -m 0755 "${S}/run.py" "${D}${datadir}/babiloo/"
28         install -d "${D}${bindir}"
29         ln -s "${datadir}/babiloo/run.py" "${D}${bindir}/babiloo"
30         install -d "${D}${datadir}/pixmaps"
31         install -m 0644 "${S}/images/babiloo.png" "${D}${datadir}/pixmaps"
32         install -d "${D}${datadir}/applications"
33         install -m 0644 "${S}/babiloo.desktop" "${D}${datadir}/applications"
34
35         cp -a "${S}/locale" "${D}${datadir}/"
36         find ${D}${datadir}/locale -name *.po -exec rm {} \;
37         rm -f ${D}${datadir}/locale/babiloo.pot
38 }
39
40 FILES_${PN} += "${datadir}/babiloo"