change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / openmoko-3rdparty / babiloo-efl_2.0.9-3.bb
1 DESCRIPTION = "EFL Dictionary Viewer. It supports dictionaries in SDictionary and StarDict format."
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 AUTHOR = "Luca Vaudano <vaudano@gmail.com>"
6 HOMEPAGE = "http://babiloo-project.org"
7 RDEPENDS = "python-elementary python-compression python-misc python-netclient"
8
9 PACKAGE_ARCH = "all"
10
11 PV = "2.0.9-3"
12 PR = "r0"
13
14 SRC_URI = "http://bazaar.launchpad.net/%7Evaudano/babiloo/efl/download/head%3A/babiloo_2.0.93.tar.g-20091127144609-qfgdm9zxdc47ap4y-1/babiloo_2.0.9-3.tar.gz;name=tarball"
15 SRC_URI[tarball.md5sum] = "3f254dbbe7dd7a4c9527e1e17686101b"
16 SRC_URI[tarball.sha256sum] = "4c4eacd8d8aec7ec7f325c18c8401d6d09986b77ddce317768360fccef78e3ef"
17
18 S = "${WORKDIR}/babiloo"
19
20 do_install() {
21         install -d "${D}${datadir}/babiloo"
22         install -d "${D}${datadir}/babiloo/dicts"
23
24         cp -a "${S}/core" "${D}${datadir}/babiloo/"
25         cp -a "${S}/efl" "${D}${datadir}/babiloo/"
26         cp -a "${S}/images" "${D}${datadir}/babiloo/"
27         install -m 0755 "${S}/run.py" "${D}${datadir}/babiloo/"
28         install -d "${D}${bindir}"
29         ln -s "${datadir}/babiloo/run.py" "${D}${bindir}/babiloo"
30         install -d "${D}${datadir}/pixmaps"
31         install -m 0644 "${S}/images/babiloo.png" "${D}${datadir}/pixmaps"
32         install -d "${D}${datadir}/applications"
33         install -m 0644 "${S}/babiloo.desktop" "${D}${datadir}/applications"
34
35         #cp -a "${S}/locale" "${D}${datadir}/"
36         #find ${D}${datadir}/locale -name *.po -exec rm {} \;
37         #rm -f ${D}${datadir}/locale/babiloo.pot
38 }
39
40 FILES_${PN} += "${datadir}/babiloo"