increase dvbapp PR.
[vuplus_openembedded] / recipes / openjade / openjade-native_1.3.2.bb
1 SECTION = "unknown"
2 DEPENDS = "opensp-native sgml-common-native"
3 LICENSE = "MIT"
4 SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
5            file://configure.patch;patch=1 \
6            file://oj-native-libosp-fix.patch;patch=1;pnum=1"
7 S = "${WORKDIR}/openjade-${PV}"
8
9 inherit autotools native
10
11 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/openjade-${PV}"
12 PACKAGES = ""
13
14 EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
15                 --enable-splibdir=${STAGING_LIBDIR} \
16                 --enable-default-catalog=${sysconfdir}/sgml/catalog \
17                 --enable-default-search-path=${datadir}/sgml"
18
19 acpaths = "-I ${S}/config"
20
21 # Trailing whitespace is important. Otherwise compiler arguments will be messed
22 # up, resulting in a fail in do_configure.
23 CFLAGS_prepend = "-I${S}/include "
24
25 do_configure () {
26         mv config/configure.in .
27         gnu-configize
28         oe_runconf
29 }
30
31 do_stage () {
32         # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
33         # for details.
34         install -m 0755 ${S}/jade/.libs/openjade ${STAGING_BINDIR_NATIVE}/openjade
35         ln -sf openjade ${STAGING_BINDIR_NATIVE}/jade
36
37         oe_libinstall -a -so -C style libostyle ${STAGING_LIBDIR}
38         oe_libinstall -a -so -C spgrove libospgrove ${STAGING_LIBDIR}
39         oe_libinstall -a -so -C grove libogrove ${STAGING_LIBDIR}
40         
41   install -d ${STAGING_DATADIR}/sgml/openjade-${PV}
42         install -m 644 dsssl/catalog ${STAGING_DATADIR}/sgml/openjade-${PV}
43         install -m 644 dsssl/*.{dtd,dsl,sgm} ${STAGING_DATADIR}/sgml/openjade-${PV}
44         
45         install-catalog --add ${sysconfdir}/sgml/openjade-${PV}.cat \
46             ${STAGING_DATADIR}/sgml/openjade-${PV}/catalog
47             
48         install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
49             ${sysconfdir}/sgml/openjade-${PV}.cat
50 }