change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / nylon / nylon-scripts_cvs.bb
1 DESCRIPTION = "This package provides the nylon specific init and configuration scripts."
2 HOMEPAGE = "http://meshcube.org/meshwiki/NyLon"
3 DEPENDS = "hostap-utils"
4 SECTION = "base"
5 PRIORITY = "optional"
6 LICENSE = "GPLv2"
7 #SRCDATE = "20060923"
8 SRCDATE = "20051022"
9 PV = "1.0.0+cvs${SRCDATE}"
10 PR = "r2"
11 RDEPENDS = "bash"
12
13 SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz \
14         file://firewall-bash.diff;patch=1"
15 S = "${WORKDIR}/${PN}"
16 INHIBIT_PACKAGE_STRIP = "1"
17
18 do_install() {
19         install -d -m 755 ${D}
20         (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
21 }
22
23 pkg_postinst() {
24 if test "x$D" != "x"; then
25         exit 1
26 else
27         update-rc.d -s hostap defaults 14
28         update-rc.d -s firewall defaults 16
29         update-rc.d -s routing defaults 17
30         update-rc.d -s emergency-ip defaults 98
31         update-rc.d -s flash-backup start 38 S . stop 38 0 6 .
32         update-rc.d -s dummydate start 50 S . stop 50 0 6 .
33
34         if ! grep -q flash-backup /etc/cron/crontabs/root; then
35                 echo "adding flash-backup crontab"
36                 test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
37                 echo "0 * * * *    /etc/init.d/flash-backup backup" >> /etc/cron/crontabs/root
38         fi
39
40         if ! grep -q reset-wlan /etc/cron/crontabs/root; then
41                 echo "adding reset-wlan crontab"
42                 test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
43                 echo "0 3 * * *    /usr/sbin/reset-wlan" >> /etc/cron/crontabs/root
44         fi
45
46         update-rc.d -s busybox-cron defaults
47 fi
48 }
49
50 pkg_postrm() {
51 #!/bin/sh -e
52 update-rc.d hostap remove
53 update-rc.d firewall remove
54 update-rc.d routing remove
55 update-rc.d emergency-ip remove
56 update-rc.d flash-backup remove
57 update-rc.d dummydate remove
58 }
59
60 CONFFILES_${PN} = "/etc/nylon/backup.list /etc/nylon/hostap.conf /etc/nylon/check-process.list \
61         /etc/nylon/interfaces.conf /etc/nylon/route.list /etc/nylon/wds-bridge.conf"