dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / ntop / ntop_3.0.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "ntop is network top"
3 SECTION = "console/network"
4 PRIORITY = "optional"
5 DEPENDS = "gdbm zlib libpcap libpng gd"
6 PR = "r1"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tgz \
9            file://${FILESDIR}/autotools.patch;patch=1 \
10            file://${FILESDIR}/plugins.patch;patch=1"
11
12 inherit autotools
13
14 EXTRA_OECONF += " --without-ssl \
15                   --with-gd-lib=${STAGING_LIBDIR} \
16                   --with-gd-include=${STAGING_INCDIR} \
17                   --with-zlib-lib=${STAGING_LIBDIR} \
18                   --with-zlib-include=${STAGING_INCDIR} \
19                   --with-pcap-lib=${STAGING_LIBDIR} \
20                   --with-pcap-include=${STAGING_INCDIR} \
21                   --with-libpng-lib=${STAGING_LIBDIR} \
22                   --with-libpng-include=${STAGING_INCDIR} \
23                   --with-gdbm-lib=${STAGING_LIBDIR} \
24                   --with-gdbm-include=${STAGING_INCDIR}"
25
26 FILES_ntop_append = " ${libdir}/ntop/plugins/*.so ${libdir}/libntop-*.so \
27                        ${libdir}/libntopreport-*.so"
28 FILES_${PN}-dev = "${includedir} ${libdir}/libntop.so ${libdir}/libntopreport.so \
29                    ${libdir}/*.a ${libdir}/libntopreport.a ${libdir}/*.la"
30 FILES_${PN}-dbg += "${libdir}/ntop/plugins/.debug"
31
32 do_configure_prepend () {
33         if [ ! -e acinclude.m4 ]; then
34                 mv acinclude.m4.ntop acinclude.m4
35         fi
36         rm -f libtool
37         cp ${STAGING_BINDIR_NATIVE}/${TARGET_SYS}-libtool libtool
38 }