Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / nmap / nmap_3.81.bb
1 DESCRIPTION = "Nmap is a command line portscanner."
2 HOMEPAGE = "http://www.insecure.org/nmap/"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 DEPENDS = "libpcap libpcre"
6 PR = "r2"
7
8 inherit autotools
9
10 SRC_URI = "http://download.insecure.org/nmap/dist-old/nmap-${PV}.tar.bz2 \
11            file://autofoo.patch;patch=1 \
12            file://remove_gtk.patch;patch=1"
13 S = "${WORKDIR}/nmap-${PV}"
14
15 EXTRA_OECONF = "--with-pcap=linux \
16                 --with-libpcap=${STAGING_LIBDIR}/.. \
17                 --with-libpcre=${STAGING_LIBDIR}/.. \
18                 --without-nmapfe \
19                 --without-openssl"
20 EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
21
22 PARALLEL_MAKE = ""
23
24 CXXFLAGS_append = " -fpermissive"
25 # Ugly hack follows -- their configure.ac doesnt match their configure ..
26 # doesnt include a check for the length type in recvfrom, so we hack it here
27 CPPFLAGS_append = " -Drecvfrom6_t=socklen_t"
28
29 do_install () {
30         oe_runmake 'prefix=${D}${prefix}' \
31                    'exec_prefix=${D}${exec_prefix}' \
32                    'bindir=${D}${bindir}' \
33                    'sbindir=${D}${sbindir}' \
34                    'mandir=${D}${mandir}' \
35                    'datadir=${D}${datadir}' \
36                    'nmapdatadir=${D}${datadir}/nmap' \
37                    install
38 }