Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / nfs-utils / nfs-utils_1.1.2.bb
1 DESCRIPTION = "userspace utilities for kernel nfs"
2 PRIORITY = "optional"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5
6 PR = "r7"
7
8 DEPENDS = "e2fsprogs-libs tcp-wrappers libevent"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
11         file://nfs-utils-tools-unset-cflags.patch;patch=1 \
12         file://nfs-utils-uclibc-compile.patch;patch=1 \
13         file://nfsserver \
14    "
15
16 S = "${WORKDIR}/nfs-utils-${PV}/"
17
18 PARALLEL_MAKE = ""
19
20 # Only kernel-module-nfsd is required here (but can be built-in)  - the nfsd module will
21 # pull in the remainder of the dependencies.
22 RDEPENDS = "portmap"
23 RRECOMMENDS = "kernel-module-nfsd"
24
25 INITSCRIPT_NAME = "nfsserver"
26 # The server has no dependencies at the user run levels, so just put
27 # it in at the default levels.  It must be terminated before the network
28 # in the shutdown levels, but that works fine.
29 INITSCRIPT_PARAMS = "defaults"
30
31 inherit autotools update-rc.d
32
33 EXTRA_OECONF = "--with-statduser=nobody \
34                 --enable-nfsv3 \
35                 --disable-nfsv4 \
36                 --disable-gss \
37                 --with-statedir=/var/lib/nfs"
38
39 do_ccompile() {
40         # UGLY HACK ALERT
41         cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
42         oe_runmake 'BUILD=1'
43 }
44
45 INHIBIT_AUTO_STAGE = "1"
46
47 do_install_append() {
48         install -d ${D}${sysconfdir}/init.d
49         install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
50
51         rm ${D}${sbindir}/rpcdebug
52 }
53
54 PACKAGES =+ "nfs-utils-client"
55 FILES_nfs-utils-client = "${base_sbindir}/*mount.nfs*"