libnsbmp: add recipe for version 0.0.1
[vuplus_openembedded] / recipes / netsurf / libnsbmp_0.0.1.bb
1 DESCRIPTION = "Libnsbmp is a decoding library for the BMP and ICO image file formats"
2 HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsbmp/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6
7 SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsbmp-${PV}-src.tar.gz"
8
9 inherit pkgconfig
10
11 EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
12
13 # NOTE: we're using default buildmode here, which results in building only
14 # static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
15 # at the moment
16
17 do_stage() {
18         oe_libinstall -a -C build-OE/ libnsbmp ${STAGING_LIBDIR}
19         install -m 0644 include/*.h ${STAGING_INCDIR}/
20 }
21
22 do_install() {
23         oe_runmake install
24 }