increase dvbapp PR.
[vuplus_openembedded] / recipes / netsurf / hubbub_0.0.1.bb
1 DESCRIPTION = "Hubbub is an HTML5 compliant parsing library"
2 HOMEPAGE = "http://www.netsurf-browser.org/projects/hubbub/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6 DEPENDS = "libparserutils"
7
8 SRC_URI = "http://www.netsurf-browser.org/projects/releases/hubbub-${PV}-src.tar.gz \
9            file://hubbub-uninitialised.patch;patch=1"
10
11 PR = "r1"
12
13 inherit pkgconfig
14
15 EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
16
17 # NOTE: we're using default buildmode here, which results in building only
18 # static libraries (.a) Not a problem as hubbub is only used by Netsurf
19 # at the moment
20
21 do_stage() {
22         oe_libinstall -a -C build-OE/ libhubbub ${STAGING_LIBDIR}
23
24         install -d ${STAGING_INCDIR}/hubbub
25         install -m 0644 include/hubbub/*.h ${STAGING_INCDIR}/hubbub
26 }
27
28
29 do_install() {
30         oe_runmake install
31 }