increase dvbapp PR.
[vuplus_openembedded] / recipes / navit / navit-icons_svn.bb
1 DESCRIPTION = "Navit is a car navigation system with routing engine."
2 LICENSE = "GPL"
3 SECTION = "x11/applications"
4 DEPENDS = "glib-2.0 gtk+"
5 RRECOMMENDS = "gpsd espeak flite"
6
7 #only icons present in the package
8 PACKAGE_ARCH = "all"
9
10 PV = "0.1.0+svnr${SRCPV}"
11 PR = "r1"
12
13 DEPENDS_shr += " librsvg-native"
14 EXTRA_OECONF = "--disable-binding-python --disable-gui-sdl --disable-samplemap --enable-avoid-float --enable-avoid-unaligned  --enable-svg2png-scaling-flag=32 --disable-speech-speech-dispatcher"
15
16 S = "${WORKDIR}/xpm"
17
18 inherit autotools
19
20 FILES_${PN} = " /usr/share/navit/xpm/"
21
22 #use different URL than navit_svn doest, to prevent upgrade/downgrade cycle in downloads dir
23 SRC_URI = "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk/navit/navit;module=xpm;proto=https \
24            file://configure.in"
25
26 do_configure_prepend() {
27   cp ${WORKDIR}/configure.in ${S}/
28   # replace include with just xpmdir variable
29   sed -i 's#.*Makefile.inc.*#xpmdir=$(pkgdatadir)/xpm#g' ${S}/Makefile.am
30   # don't install desktopfile and icons
31   sed -i 's/^\(EXTRADIST.*\) $(DESKTOPFILE_DATA) $(ICON128_DATA) $(ICON22_DATA) \(.*\)$/\1\2/g' ${S}/Makefile.am
32 }