increase dvbapp PR.
[vuplus_openembedded] / recipes / nautilus / nautilus_2.24.2.bb
1 # nautilus OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 inherit gnome
6
7 SRC_URI += "file://idl-sysroot.patch;patch=1"
8 export SYSROOT = "${STAGING_DIR_HOST}"
9
10 LICENSE="GPL"
11
12 PR = "r1"
13
14 DEPENDS += " gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
15 RDEPENDS = "gvfs"
16
17 EXTRA_OECONF = " --disable-gtk-doc  --disable-update-mimedb "
18
19 PACKAGES += " libnautilus"
20
21 FILES_${PN} += "${datadir}/icons  /usr/libexec/ "
22 FILES_libnautilus = "/usr/lib/*.so*"
23 FILES_${PN}-dbg += "/usr/libexec/.debug"
24
25 # We need native orbit-idl with target idl files. No way to say it in a clean way:
26 do_configure_append () {
27         find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
28 }
29
30 do_stage() {
31         autotools_stage_all
32 }