increase dvbapp PR
[vuplus_openembedded] / recipes / mythtv / gmyth-upnp_0.7.0.bb
1 DESCRIPTION = "GMyth is a library to access MythTV backend services."
2 LICENSE = "LGPLv2""
3 HOMEPAGE = "http://gmyth.sourceforge.net/wiki/index.php/Main_Page"
4
5 PR = "r3"
6
7 DEPENDS = "glib-2.0 mysql gmyth libupnp"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/gmyth/${PN}_0.7-indt1.tar.gz"
10 S = "${WORKDIR}/${PN}"
11
12 inherit autotools
13
14 AUTOTOOLS_STAGE_PKGCONFIG = "1"
15
16 do_compile_append() {
17         sed -i -e s:${STAGING_DIR_TARGET}::g \
18                -e s,Version:,Version:\ 0\.7\.0,g \
19                -e s:/${TARGET_SYS}::g \   
20                -e s:clinkc::g \
21                   gmyth-upnp.pc
22 }
23
24 do_install_append() {
25         mv ${D}/${bindir}/test ${D}/${bindir}/gmyth-upnp-test
26 }
27
28 do_stage() {
29         autotools_stage_all
30 }
31