change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / mutt / mutt_1.5.9i.bb
1 SECTION = "console/network"
2 DEPENDS = "ncurses gnutls gpgme"
3 DESCRIPTION = "Mutt is a small but very powerful text-based \
4 MIME mail client. It is highly configurable, and is well-suited \
5 to the mail power user with advanced features like key \
6 bindings, keyboard macros, mail threading, regular expression \
7 searches, and a powerful pattern matching language for selecting \
8 groups of messages."
9 LICENSE = "GPL"
10 PR = "r0"
11 SRC_URI = "ftp://ftp.mutt.org/mutt/devel/mutt-${PV}.tar.gz \
12            http://mutt.kiev.ua/download/mutt-1.5.9/patch-1.5.9.rr.compressed.gz;patch=1 \
13            http://mutt.kiev.ua/download/mutt-1.5.9/patch-1.5.9.vvv.nntp.gz;patch=1 \
14            http://mutt.kiev.ua/download/mutt-1.5.9/patch-1.5.9.vvv.initials.gz;patch=1 \
15            http://mutt.kiev.ua/download/mutt-1.5.9/patch-1.5.9.vvv.quote.gz;patch=1 \
16            file://patch-1.5.9i.sidebar.20050628.txt.hackedfornntp;patch=1 \
17            file://sidebar-nntp-clash.patch;patch=1 \
18            file://cppflags.patch;patch=1 \
19            file://posix1_lim.patch;patch=1 \
20            file://makedoc.patch;patch=1 "
21 #          file://configure.patch;patch=1"
22 S = "${WORKDIR}/mutt-1.5.9"
23
24 DEFAULT_PREFERENCE = "-1"
25
26 inherit autotools
27
28 EXTRA_OECONF = "--enable-gpgme --with-curses=${STAGING_LIBDIR}/.. \
29                 --enable-pop --enable-imap --with-gnutls --enable-compressed --enable-nntp"
30
31 do_compile_prepend () {
32         ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makedoc.c -o makedoc
33 }