Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / mutt / mutt_1.5.15.bb
1 SECTION = "console/network"
2 DEPENDS = "ncurses gnutls gpgme"
3 DESCRIPTION = "Mutt is a small but very powerful text-based \
4 MIME mail client. It is highly configurable, and is well-suited \
5 to the mail power user with advanced features like key \
6 bindings, keyboard macros, mail threading, regular expression \
7 searches, and a powerful pattern matching language for selecting \
8 groups of messages."
9 LICENSE = "GPL"
10 PR = "r0"
11 SRC_URI = "ftp://ftp.mutt.org/mutt/devel/mutt-${PV}.tar.gz \
12            http://mutt.org.ua/download/mutt-1.5.15/patch-1.5.15.vvv.nntp.2.gz;patch=1 \
13            http://mutt.org.ua/download/mutt-1.5.15/patch-1.5.15.vvv.initials.gz;patch=1 \
14            http://mutt.org.ua/download/mutt-1.5.15/patch-1.5.15.vvv.quote.gz;patch=1 \
15            file://patch-1.5.15.sidebar.20070408.txt;patch=1 \
16            file://makedoc.patch;patch=1 "
17
18 S = "${WORKDIR}/mutt-1.5.15"
19
20 inherit autotools
21
22 EXTRA_OECONF = "--enable-gpgme --with-curses=${STAGING_LIBDIR}/.. \
23                 --enable-pop --enable-imap --with-gnutls --enable-nntp"
24
25 do_compile_prepend () {
26         ${BUILD_CC} makedoc.c -o makedoc
27 }