increase dvbapp PR.
[vuplus_openembedded] / recipes / musicpd / mpd_0.14.2.bb
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libao zlib libmikmod flac audiofile virtual/libiconv faad2 pulseaudio \
6            ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag lame', d)}"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.bz2 \
9            file://mpd/mpd.conf \
10            file://mpd/mpd.init"
11
12 PR = "r3"
13
14 inherit autotools update-rc.d
15 INITSCRIPT_NAME = "mpd"
16
17 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
18 # be built, instead we use the OE built versions which should be installed
19 # in staging - remove the --with and replace with --enable to use the local
20 # versions.
21
22 EXTRA_OECONF = "\
23                 --enable-ogg \
24                 --with-id3tag-libraries=${STAGING_LIBDIR} \
25                 --with-id3tag-includes=${STAGING_INCDIR} \
26                 --with-mad-libraries=${STAGING_LIBDIR} \
27                 --with-mad-includes=${STAGING_INCDIR} \
28         --with-faad-libraries=${STAGING_LIBDIR} \
29                 --with-faad-includes=${STAGING_INCDIR} \
30         --disable-curl \
31         --disable-ffmpeg \
32         --disable-jack \
33         --enable-pulse \
34         --enable-mod \
35         --disable-oggflac \
36         --with-lame-includes=${STAGING_INCDIR}"
37
38 do_compile_prepend() {
39     find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
40 }
41
42 do_install_append() {
43     install -d ${D}${sysconfdir}/init.d
44     install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
45     install -m 644 ${WORKDIR}/mpd/mpd.conf ${D}${sysconfdir}/mpd.conf
46 }
47