enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / mtools / mtools_4.0.10.bb
1 # mtools OE build file
2 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Copyright (C) 2009, O.S. Systems Software Ltda. All Rights Reserved
4 # Released under the MIT license (see packages/COPYING)
5
6 DESCRIPTION="Mtools is a collection of utilities for accessing MS-DOS disks from Unix without mounting them."
7 HOMEPAGE="http://mtools.linux.lu"
8 LICENSE="GPL"
9
10 SRC_URI="http://ftp.gnu.org/gnu/mtools/mtools-${PV}.tar.bz2 \
11         file://m486.patch;patch=1 \
12         file://mtools-makeinfo.patch;patch=1 \
13         file://plainio.patch;patch=1 \
14         file://use-sg_io.patch;patch=1"
15
16 PR = "r1"
17
18 inherit autotools
19
20 EXTRA_OECONF = "--without-x"
21
22 # Don't try to run install-info -- it'll fail on non-Debian build systems.
23 EXTRA_OEMAKE = "INSTALL_INFO="
24
25 do_fix_perms() {
26         chmod 644 ${S}/*.c ${S}/*.h
27 }
28
29 addtask fix_perms after do_unpack before do_patch