dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / mtd / mtd-utils_1.2.0+git.bb
1 require mtd-utils.inc
2
3 DEPENDS += "e2fsprogs-libs"
4 PR = "r4"
5
6 ARM_INSTRUCTION_SET = "arm"
7
8 # This is the default package, thus we lock to a specific git version so 
9 # upstream changes will not break builds.
10
11 TAG = "ea429635388f7bb53f62c41ec3d5ccf5fa207370"
12
13 SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
14            file://add-exclusion-to-mkfs-jffs2-git-2.patch;patch=1 \
15            file://fix-ignoreerrors-git.patch;patch=1 \
16            file://lzo_1x-git.patch;patch=1"
17
18 SRC_URI_vuplus = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
19            file://add-exclusion-to-mkfs-jffs2-git-2.patch;patch=1 \
20            file://fix-ignoreerrors-git.patch;patch=1 \
21            file://makefile.patch;patch=1 \
22            file://lzo_1x-git.patch;patch=1"
23
24 S = "${WORKDIR}/git/"
25
26 do_configure_prepend() {
27         for i in $(find . -name "Makefile") ; do
28                 sed -i -e s:lzo2:lzo:g $i
29         done
30         if [ -e mkfs.ubifs/compr.c ]; then
31                 sed -i -e s:lzo/::g mkfs.ubifs/compr.c
32         fi
33 }