dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / mtd / mtd-utils_1.0.0+git.bb
1 DESCRIPTION = "Tools for managing memory technology devices."
2 SECTION = "base"
3 DEPENDS = "zlib lzo"
4 HOMEPAGE = "http://www.linux-mtd.infradead.org/"
5 LICENSE = "GPLv2"
6 PR = "r8"
7
8 # This is the default package, thus we lock to a specific git version so 
9 # upstream changes will not break builds.
10
11 TAG = "9845d92440bd87739c89edd000fd6e0c47fab185"
12 # As of 2007/27/07, see http://git.infradead.org/?p=mtd-utils.git;a=shortlog
13
14 SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
15            file://add-exclusion-to-mkfs-jffs2-git.patch;patch=1 \
16            file://fix-ignoreerrors-git.patch;patch=1 \
17            file://lzo_1x.patch;patch=1"
18
19 S = "${WORKDIR}/git/"
20
21 EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR'"
22
23 do_stage () {
24         install -d ${STAGING_INCDIR}/mtd
25         for f in ${S}/include/mtd/*.h; do
26                 install -m 0644 $f ${STAGING_INCDIR}/mtd/
27         done
28         for binary in ${mtd_utils}; do
29                 install -m 0755 $binary ${STAGING_BINDIR}
30         done
31 }
32
33 mtd_utils = "ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
34              mkfs.jffs ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
35              flashcp nandwrite jffs2dump sumtool"
36
37 do_install () {
38         install -d ${D}${bindir}
39         install -d ${D}${includedir}/mtd
40         for binary in ${mtd_utils}; do
41                 install -m 0755 $binary ${D}${bindir}
42         done
43         for f in ${S}/include/mtd/*.h; do
44                 install -m 0644 $f ${D}${includedir}/mtd
45         done
46 }
47
48 PACKAGES =+ "mkfs-jffs mkfs-jffs2"
49 FILES_mkfs-jffs = "${bindir}/mkfs.jffs"
50 FILES_mkfs-jffs2 = "${bindir}/mkfs.jffs2"
51