increase dvbapp PR.
[vuplus_openembedded] / recipes / mozilla / firefox_hg.bb
1 DESCRIPTION = "Mozilla Mobile browser"
2 DEPENDS += "autoconf213-native cairo alsa-lib sqlite3"
3
4 PV = "3.4+3.5b4"
5 MOZPV = "3.5b4"
6 PR = "r0"
7
8 DEFAULT_PREFERENCE = "-1"
9
10 SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=8c9a6d851018 \
11            file://jsautocfg.h \
12            file://jsautocfg-dontoverwrite.patch;patch=1 \
13 "
14
15 S = "${WORKDIR}/mozilla-central"
16
17 inherit mozilla
18 require firefox.inc
19
20 PARALLEL_MAKE = ""
21 export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
22 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
23
24 export LIBXUL_DIST="${S}/objdir/xulrunner/dist/"
25 CFLAGS_append = " -DMOZ_GFX_OPTIMIZE_MOBILE "
26
27 do_configure_prepend() {
28         sed -i -e 's:head\ -1:head\ -n1:g' client.mk
29         oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
30 }
31
32 do_compile_prepend() {
33         # A compile time assert is broken:
34         # http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/include/prlog.h#259
35         for i in $(find ${S} -name "autoconf.mk") ; do 
36                 sed -i -e s:fsigned-char:fno-signed-char:g $i
37         done
38
39         cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
40         sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
41                -e  s:'$(OS_TEST)':${TARGET_ARCH}:g \
42                    ${S}/security/coreconf/Linux.mk
43 }
44
45
46 do_stage() {
47         :
48 }       
49
50
51 FILES_${PN} += "${libdir}/fennec" 
52