increase dvbapp PR.
[vuplus_openembedded] / recipes / mozilla / firefox_3.5b4.bb
1 DEPENDS += "cairo sqlite"
2
3 PV = "3.0.1+3.5b4"
4 MOZPV = "3.5b4"
5 PR = "r2"
6
7 SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/${MOZPV}-candidates/build1/source/firefox-${MOZPV}-source.tar.bz2 \
8         file://jsautocfg.h \
9         file://jsautocfg-dontoverwrite.patch;patch=1 \
10 "
11
12 S = "${WORKDIR}/mozilla-1.9.1"
13
14 DEFAULT_PREFERENCE = "-10"
15
16 inherit mozilla
17 require firefox.inc
18
19 export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
20 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
21
22 do_configure_prepend() {
23         sed -i -e s:'head -1':'head -n1':g client.mk
24         oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
25 }
26
27 do_compile_prepend() {
28         cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
29         sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
30                -e  s:'$(OS_TEST)':${TARGET_ARCH}:g \
31                    ${S}/security/coreconf/Linux.mk
32 }
33
34 do_stage() {
35         install -d ${STAGING_INCDIR}/firefox-${MOZPV}
36         cd dist/sdk/include
37                 rm -rf obsolete
38         headers=`find . -name "*.h"`
39         for f in $headers
40         do
41                 install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${MOZPV}/
42         done
43         # removes 2 lines that call absent headers
44         sed -e '178,179d' ${STAGING_INCDIR}/firefox-${MOZPV}/nsIServiceManager.h
45 }
46