increase dvbapp PR.
[vuplus_openembedded] / recipes / monotone / monotone-6_0.27.bb
1 DESCRIPTION = "Monotone is a distributed Source Control System"
2 HOMEPAGE = "http://www.venge.net/monotone"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6 DEPENDS = "boost"
7
8 S = "${WORKDIR}/monotone-${PV}"
9 # no cross compile support - it tries to run the test program even with
10 # --enable_ipv6=yes
11 EXTRA_OECONF = "--disable-ipv6 \
12                 --disable-dependency-tracking \
13                 --disable-rpath \
14                 --disable-nls \
15                 --with-gnu-ld \
16                 --with-bundled-lua --with-bundled-sqlite"
17
18 inherit autotools
19
20 # Release 0.22 reveals bugs in g++ for thumb (g++ generates
21 # relocations which the linker cannot represent)
22 #FIXME: remove the following
23 ARM_INSTRUCTION_SET = "arm"
24
25 PR = "r0"
26
27 SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
28            file://txt2c-cross-post-0.22.patch;patch=1 \
29            file://uclibc.database.hh.stdarg.patch;patch=1 \
30            file://configure.ac-no-sync-with-stdio-0.26.patch;patch=1 \
31            "
32 # This makes the testsuite as a package and renames the monotone executable
33 # to include the netsync suffix.
34 do_install_append() {
35         install -d ${D}${tsd}
36         install -c -m 755 testsuite ${D}${tsd}/testsuite
37         cp -pPR tests ${D}${tsd}/tests
38 }
39
40 PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-testsuite"
41 tsd = "/home/monotone/${PN}"
42 FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
43 RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch perl perl-modules"
44