increase dvbapp PR.
[vuplus_openembedded] / recipes / mono / mono-native_1.2.5.1.bb
1 require mono_1.2.5.inc
2 PR = "r2"
3 DEPENDS = "glib-2.0-native perl-native"
4
5 SRC_URI += "file://mono-fix-libdir-path.patch;patch=1"
6
7 PARALLEL_MAKE = ""
8
9 inherit native
10
11 do_stage_prepend() {
12         install -m 755 ${S}/mono/monoburg/monoburg ${STAGING_BINDIR}
13 }
14
15 do_fix_libtool_name() {
16         # inherit native will make that all native tools that are being
17         # built are prefixed with something like "i686-linux-",
18         # including libtool. Fix up some hardcoded libtool names:
19         for i in "${S}"/runtime/*-wrapper.in; do
20                 sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
21         done
22 }
23 addtask fix_libtool_name after do_patch before do_configure