increase dvbapp PR.
[vuplus_openembedded] / recipes / midpath / midpath-cldc_0.2+0.3rc2.bb
1 require midpath-common.inc
2
3 PR = "r0"
4
5 SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
6
7 S = "${WORKDIR}/midpath-0.3rc2"
8
9 DESCRIPTION = "Implementation of the CLDC profile for use in the MIDPath library"
10 RPROVIDES  = "midpath-cldc java-cldc1.1"
11
12 JAR = "midpath-cldc1.1.jar"
13
14 do_compile() {
15   midpath_build \
16     --disable-midpath \
17     --disable-sdljava-cldc \
18     --disable-escher-cldc \
19     --disable-jlayerme-cldc \
20     --disable-jorbis-cldc \
21     --disable-avetanabt-cldc \
22     --disable-jgl-cldc \
23     --disable-web_services-api \
24     --disable-location-api \
25     --disable-messaging-api \
26     --disable-svg-api \
27     --disable-opengl-api \
28     --disable-m3g-api \
29     --disable-demos \
30     --with-cldc-jar=dist/${JAR}
31 }
32
33 do_install() {
34         install -d ${D}${datadir}/midpath-cldc
35         install -m 0644 dist/${JAR} ${D}${datadir}/midpath-cldc
36 }
37
38 do_stage() {
39         install -d ${STAGING_DATADIR}/midpath-cldc
40         install -m 0644 dist/${JAR} ${STAGING_DATADIR}/midpath-cldc
41 }
42         
43 PACKAGES = "${PN}"
44
45 FILES_${PN}  = "${datadir}/midpath-cldc/${JAR}"