increase dvbapp PR.
[vuplus_openembedded] / recipes / mesa / freeglut_2.4.0.bb
1 DESCRIPTION = "freeglut is a completely OpenSourced alternative to the OpenGL Utility Toolkit (GLUT) library. "
2 LICENSE = "MIT/X11"
3
4 DEPENDS = "virtual/libgl"
5
6 SRC_URI = "http://dfn.dl.sourceforge.net/sourceforge/freeglut/freeglut-${PV}.tar.gz"
7
8 inherit autotools lib_package
9
10 export CCLD="${CXX}"
11
12 do_configure_prepend() {
13         sed -i -e s:-Werror::g -e s:AC_PROG_CC:AC_PROG_CXX:g configure.ac
14 }
15
16 do_configure_append() {
17         for i in $(find . -name "Makefile") ; do
18                 sed -i -e /^CCLD/d $i
19         done
20 }
21
22
23 do_stage() {
24         autotools_stage_all
25 }
26