increase dvbapp PR.
[vuplus_openembedded] / recipes / mc / mc_4.6.2.bb
1 require mc.inc
2 PR = "r6"
3 HOMEPAGE = "http://www.midnight-commander.org/"
4
5 S = "${WORKDIR}/${PN}-${PV}"
6
7 # most of these fixes were copied from openSUSE Factory.
8 SRC_URI = "http://www.midnight-commander.org/downloads/${P}.tar.gz \
9            file://mhl-stdbool.patch;patch=1 \
10            file://mc-utf8.patch;patch=1 \
11            file://00-70-utf8-common.patch;patch=1 \
12            file://00-73-utf8-bottom-buttons-width.patch;patch=1 \
13            file://00-75-utf8-cmdline-help.patch;patch=1 \
14            file://00-76-utf8-hotlist-highlight.patch;patch=1 \
15            file://00-77-utf8-filename-search-highlight.patch;patch=1 \
16            file://mc-utf8-nlink.patch;patch=1 \
17            file://mc-utf8-look-and-feel.patch;patch=1 \
18            file://mc-utf8-slang-codeset.patch;patch=1 \
19            file://99_regexp-replace-fixed.patch;patch=1 \
20            file://99b_fix-regex-pattern-lengths.patch;patch=1 \
21            file://multi-press-f-keys.patch;patch=1 \
22            file://cross-compile.patch;patch=1 \
23            file://01_ftpfs_symlink.patch;patch=1 \
24            file://02_ignore_ftp_chmod_error.patch;patch=1 \
25            file://mc-cursor-appearance.patch;patch=1 \
26            file://mc-esc-seq.patch;patch=1"
27
28 EXTRA_OECONF = "--without-x --without-samba \
29 --without-nfs --without-gpm-mouse --enable-charset \
30 ac_cv_path_PERL=${bindir}/perl \
31 ac_cv_path_ZIP=${bindir}/zip \
32 ac_cv_path_UNZIP=${bindir}/unzip \
33 "
34
35 do_unpack_append() {
36         bb.build.exec_func('do_utf8_conversion', d)
37 }
38
39 do_utf8_conversion() {
40         cd ${S}/lib
41         iconv -f iso8859-1 -t utf-8 -o mc.hint.tmp mc.hint && mv mc.hint.tmp mc.hint
42         iconv -f iso8859-1 -t utf-8 -o mc.hint.es.tmp mc.hint.es && mv mc.hint.es.tmp mc.hint.es
43         iconv -f iso8859-1 -t utf-8 -o mc.hint.it.tmp mc.hint.it && mv mc.hint.it.tmp mc.hint.it
44         iconv -f iso8859-1 -t utf-8 -o mc.hint.nl.tmp mc.hint.nl && mv mc.hint.nl.tmp mc.hint.nl
45         iconv -f iso8859-2 -t utf-8 -o mc.hint.cs.tmp mc.hint.cs && mv mc.hint.cs.tmp mc.hint.cs
46         iconv -f iso8859-2 -t utf-8 -o mc.hint.hu.tmp mc.hint.hu && mv mc.hint.hu.tmp mc.hint.hu
47         iconv -f iso8859-2 -t utf-8 -o mc.hint.pl.tmp mc.hint.pl && mv mc.hint.pl.tmp mc.hint.pl
48         iconv -f iso8859-5 -t utf-8 -o mc.hint.sr.tmp mc.hint.sr && mv mc.hint.sr.tmp mc.hint.sr
49         iconv -f koi8-r -t utf8 -o mc.hint.ru.tmp mc.hint.ru && mv mc.hint.ru.tmp mc.hint.ru
50         iconv -f koi8-u -t utf8 -o mc.hint.uk.tmp mc.hint.uk && mv mc.hint.uk.tmp mc.hint.uk
51         iconv -f big5 -t utf8 -o mc.hint.zh.tmp mc.hint.zh && mv mc.hint.zh.tmp mc.hint.zh
52         iconv -f iso8859-5 -t utf-8 -o mc.menu.sr.tmp mc.menu.sr && mv mc.menu.sr.tmp mc.menu.sr
53         # convert docs to utf-8
54         cd ${S}/doc/es
55         iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
56         iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
57         cd ${S}/doc/hu
58         iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
59         iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
60         cd ${S}/doc/it
61         iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
62         iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
63         cd ${S}/doc/pl
64         iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
65         iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
66         cd ${S}/doc/ru
67         iconv -f koi8-r -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
68         iconv -f koi8-r -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
69         cd ${S}/doc/sr
70         iconv -f iso8859-5 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
71         iconv -f iso8859-5 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
72         iconv -f iso8859-5 -t utf-8 -o mcserv.8.in.tmp mcserv.8.in && mv mcserv.8.in.tmp mcserv.8.in
73         cd ${S}
74 }
75
76 do_configure_prepend() {
77         # remove dangling symlinks
78         find ${S} -type l -exec rm {} \;
79 }