Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / matchbox2 / matchbox2_2.0.bb
1 DESCRIPTION = "Metapackage for Matchbox2 suite"
2 LICENSE = "GPL"
3 DEPENDS = "matchbox-wm-2 matchbox-panel-2 matchbox-desktop-2"
4 RDEPENDS = "matchbox-wm-2 matchbox-panel-2 matchbox-desktop-2"
5 SECTION = "x11/wm"
6 PR = "r1"
7
8 SRC_URI = "file://matchbox-session-2.in \
9            file://defaults.in \
10 "
11 inherit update-alternatives
12
13 ALTERNATIVE_NAME = "x-window-manager"
14 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
15 ALTERNATIVE_PATH = "${bindir}/matchbox-session-2"
16 ALTERNATIVE_PRIORITY = "20"
17
18 do_compile() {
19         sed "s:@datadir@:${datadir}:g;s:@sysconfdir@:${sysconfdir}:g" <${WORKDIR}/matchbox-session-2.in >matchbox-session-2
20         sed "s:@datadir@:${datadir}:g;s:@sysconfdir@:${sysconfdir}:g" <${WORKDIR}/defaults.in >defaults
21 }
22
23 do_install() {
24         mkdir -p ${D}${bindir} ${D}${sysconfdir}/matchbox2
25         install -m 0755 matchbox-session-2 ${D}${bindir}
26         install -m 0644 defaults ${D}${sysconfdir}/matchbox2
27 }
28
29 FILES_${PN} += "${sysconfdir}/matchbox2"