increase dvbapp PR.
[vuplus_openembedded] / recipes / matchbox2 / matchbox-panel-2-icon-themes_0.0.1.bb
1 DESCRIPTION = "icon theme for matchbox-panel-2"
2 LICENSE = "GPLv2"
3 SECTION = "x11/panels"
4 DEPENDS = "imagemagick-native"
5 RPROVIDES_${PN} = "matchbox-panel-2-icon-theme"
6 PACKAGE_ARCH = "all"
7 SRCREV_FORMAT = "startup"
8 PV = "0.0.1+svnr${SRCPV}"
9 PR = "r0"
10
11 inherit gtk-icon-cache
12
13 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-panel-2/applets/battery/data;proto=http;maxrev=1918 \
14            svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-panel-2/applets/startup/data;proto=http;name=startup \
15            svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-panel-2/applets/brightness/data;proto=http \
16            file://user-desktop.png \
17            file://task-switcher.png \
18 "
19 S = "${WORKDIR}"
20
21 do_install() {
22         cd ${S}
23         mkdir -p ${D}${datadir}/icons/HighContrast/48x48/status ${D}${datadir}/icons/HighContrastInverse/48x48/status
24         install -m 0644 matchbox-panel-2/applets/battery/data/*.png ${D}${datadir}/icons/HighContrastInverse/48x48/status/
25         mkdir -p ${D}${datadir}/icons/HighContrast/32x32/status ${D}${datadir}/icons/HighContrastInverse/32x32/status
26         install -m 0644 matchbox-panel-2/applets/brightness/data/*.png ${D}${datadir}/icons/HighContrastInverse/32x32/status/
27         mkdir -p ${D}${datadir}/icons/HighContrast/32x32/animations ${D}${datadir}/icons/HighContrastInverse/32x32/animations
28         install -m 0644 matchbox-panel-2/applets/startup/data/*.png ${D}${datadir}/icons/HighContrastInverse/32x32/animations/
29         cd ${D}${datadir}/icons/HighContrastInverse
30         for PNG in */*/*.png ; do
31                 convert -negate $PNG ../HighContrast/$PNG
32         done
33         cd ${S}
34         mkdir -p ${D}${datadir}/icons/HighContrast/32x32/apps ${D}${datadir}/icons/HighContrastInverse/32x32/apps
35         install -m 0644 user-desktop.png task-switcher.png ${D}${datadir}/icons/HighContrast/32x32/apps/
36         cd ${D}${datadir}/icons/HighContrast
37         for PNG in 32x32/apps/*.png ; do
38                 convert -negate $PNG ../HighContrastInverse/$PNG
39         done
40         cd ${S}
41
42         # FIXME: The default vendor provided theme uses "white on
43         # transparent" style and it is invisible with the default GTK+
44         # style. We need a better solution for fallback icons and dark
45         # themes. For now, define only "black on transparent" as
46         # hicolor. It is still pretty ugly: Hicolor is expected to be
47         # hicolor, makes icons invisible in dark themes.
48         rm -r ${D}${datadir}/icons/HighContrastInverse
49         mv ${D}${datadir}/icons/HighContrast ${D}${datadir}/icons/hicolor
50 }
51
52 FILES_${PN} += "${datadir}/icons/*"