change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / matchbox-wm / matchbox-wm_1.1.bb
1 require matchbox-wm.inc
2
3 DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf "
4 RDEPENDS = ""
5
6 PR ="r2"
7
8 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.1/matchbox-window-manager-${PV}.tar.gz \
9            file://kbdconfig"
10
11 S = "${WORKDIR}/matchbox-window-manager-${PV}"
12
13 inherit autotools pkgconfig update-alternatives
14
15 FILES_${PN} = "${bindir}/* \
16                ${datadir}/matchbox \
17                ${sysconfdir}/matchbox \
18                ${datadir}/themes/blondie/matchbox \
19                ${datadir}/themes/Default/matchbox \
20                ${datadir}/themes/MBOpus/matchbox"
21
22 ALTERNATIVE_NAME = "x-window-manager"
23 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
24 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
25 ALTERNATIVE_PRIORITY = "10"
26
27 EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
28
29 do_install_prepend() {
30         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
31 }
32