increase dvbapp PR.
[vuplus_openembedded] / recipes / matchbox-wm / matchbox-wm_1.0.bb
1 require matchbox-wm.inc
2
3 DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf "
4 RDEPENDS = ""
5
6 PR ="r3"
7
8
9 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.0/matchbox-window-manager-${PV}.tar.gz \
10            file://kbdconfig"
11
12 S = "${WORKDIR}/matchbox-window-manager-${PV}"
13
14 inherit autotools pkgconfig update-alternatives
15
16 FILES_${PN} = "${bindir}/* \
17                ${datadir}/matchbox \
18                ${sysconfdir}/matchbox \
19                ${datadir}/themes/blondie/matchbox \
20                ${datadir}/themes/Default/matchbox \
21                ${datadir}/themes/MBOpus/matchbox"
22
23 ALTERNATIVE_NAME = "x-window-manager"
24 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
25 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
26 ALTERNATIVE_PRIORITY = "10"
27
28 EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
29
30 do_install_prepend() {
31         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
32 }
33