dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / man / man_1.5p.bb
1 LICENSE = "GPL"
2 SECTION = "base"
3 DESCRIPTION = "The man page suite, including man, apropos, \
4 and whatis consists of programs that are used to read most \
5 of the documentation available on a Linux system."
6 PR = "r5"
7 RDEPENDS_${PN} = "less groff"
8
9 # Note: The default man.conf uses wrong names for GNU eqn and troff,
10 # so we install our own
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/man/man-${PV}.tar.bz2 \
12                 file://man.conf"
13
14 # Disable parallel make or it tries to link objects before they are built
15 PARALLEL_MAKE = ""
16
17 EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
18 GS = "-DGREPSILENT=\"q\""
19 DEFS = "-DUSG -DDO_COMPRESS ${GS}"
20
21 do_configure() {
22         # this doesn't support cross compilation, so it generates a
23         # bogus configuration
24         sed -i /^LDFLAGS/d src/Makefile.in
25         ./configure -d -confdir ${sysconfdir}
26 }
27
28 do_compile() {
29         # this fixes up the cross compilation by killing the bogus DEFS
30         (cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
31                 makemsg.c -o makemsg)
32         oe_runmake 'DEFS=${DEFS}'
33 }
34
35 do_install() {
36         oe_runmake 'PREFIX=${D}' 'DEFS=${DEFS}' install
37         install -m 644 ${WORKDIR}/man.conf ${D}/etc
38 }
39
40 FILES_${PN} = "${bindir}/* ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
41                ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
42                /bin /sbin /lib/*/ /lib/*.so*"