Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[vuplus_openembedded] / recipes / lzma / lzma_4.17.bb
1 DESCRIPTION = "LZMA is a general compression method. LZMA provides high compression ratio and very fast decompression."
2 HOMEPAGE = "http://www.7-zip.org/"
3 LICENSE = "LGPL"
4 DEPENDS = "zlib"
5 PR = "r1"
6
7 SRC_URI = "http://www.7-zip.org/dl/lzma417.tar.bz2 \
8            file://lzma-406-zlib-stream.patch;patch=1;pnum=2"
9
10 S = "${WORKDIR}/SRC"
11
12 EXTRA_OEMAKE += "CXX_C='${CC}'"
13
14 CFLAGS += "-c -I${S}"
15
16 # If you run into "internal compiler error" failures with gcc, disable optimization
17 # using -O0, or use -O1 or -O2 instead of -Os. (reported failure: gcc 3.4.4 for sh4)
18 #FULL_OPTIMIZATION = "-O0"
19
20 # One such reported failure is a cross-gcc 3.4.4 for sh4:
21 FULL_OPTIMIZATION_sh4 = "-O1"
22
23 do_compile() {
24         oe_runmake -C 7zip/Compress/LZMA_Alone
25         oe_runmake -C 7zip/Compress/LZMA_Lib
26 }
27
28 do_install() {
29         install -d ${D}${bindir} ${D}${libdir}
30         install -m 0755 7zip/Compress/LZMA_Alone/lzma ${D}${bindir}
31         oe_libinstall -a -C 7zip/Compress/LZMA_Lib liblzma ${D}${libdir}
32 }
33
34 do_stage () {
35         oe_libinstall -a -C 7zip/Compress/LZMA_Lib liblzma ${STAGING_LIBDIR}
36 }